summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bce2c43dfc68..6ab63d0e947f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_tag=latest
pkgname=whatpulse
pkgver=5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Measures your keyboard, mouse and application usage, network traffic and uptime."
arch=('x86_64')
@@ -14,11 +14,14 @@ url=http://www.whatpulse.org
license=(custom:whatpulse_tos)
depends=(
- qt5-svg
+ qt6-svg
+ qt6-charts
+ qt6-5compat
hicolor-icon-theme
)
makedepends=(
imagemagick
+ patchelf
)
optdepends=(
'libpcap: for capturing network statistics'
@@ -30,7 +33,7 @@ source=(
source_x86_64=("${pkgname}-${pkgver}-amd64.AppImage::https://d2bz2twqkobp4d.cloudfront.net/${_tag:-$pkgver}/linux/whatpulse-linux-${_tag:-$pkgver}_amd64.AppImage")
sha256sums=('5a4a6676a6b513824eeac8a2accd6de9e8bd2bc11b3e2967fa2b2a18d29fa35d'
'cfea47f15bb3ba2494a7b1d50367139dc12709fc1e8ba0b25d86ee5f09748619')
-sha256sums_x86_64=('9d4579339d255152748a8d1ed842dc9e0d83347ac57c4fd3cb6e3a6e14ec7a2a')
+sha256sums_x86_64=('80e11e721c447f8d5137905a371a51ea5b21e9e55d2f5e0c00e48be28c0b2f87')
_extract() {
./"${pkgname}-${pkgver}-amd64.AppImage" --appimage-extract "$1"
@@ -42,6 +45,7 @@ prepare() {
_extract 'whatpulse.png'
_extract 'usr/share/icons/hicolor/512x512/apps/whatpulse.png'
ln -sf squashfs-root sfs
+ patchelf --remove-rpath sfs/usr/bin/whatpulse
}
package() {