summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0cf5a1eff28e..65386757204b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_tag=latest
pkgname=whatpulse
pkgver=5.4
-pkgrel=1
+pkgrel=2
pkgdesc="Measures your keyboard, mouse and application usage, network traffic and uptime."
arch=('x86_64')
@@ -29,11 +29,13 @@ optdepends=(
)
source=(
'whatpulse.desktop'
+ 'whatpulse.sh'
LICENSE
)
source_x86_64=("${pkgname}-${pkgver}-amd64.AppImage::https://releases.whatpulse.org/${_tag:-$pkgver}/linux/whatpulse-linux-${_tag:-$pkgver}_amd64.AppImage")
sha256sums=('5a4a6676a6b513824eeac8a2accd6de9e8bd2bc11b3e2967fa2b2a18d29fa35d'
- 'cfea47f15bb3ba2494a7b1d50367139dc12709fc1e8ba0b25d86ee5f09748619')
+ '9b30dbf9e33a4fecf21e3a26e7fe37509d884cf84c092751a4ef2f48a762268c'
+ 'cfea47f15bb3ba2494a7b1d50367139dc12709fc1e8ba0b25d86ee5f09748619')
sha256sums_x86_64=('533b1b28120a25f3db625425f42dfbc559180a3dfb4e1f9c6156cf27b4a646f4')
_extract() {
@@ -57,7 +59,9 @@ prepare() {
}
package() {
- install -Dm755 sfs/usr/bin/whatpulse "${pkgdir}/usr/bin/whatpulse"
+ # whatpulse
+ install -Dm755 whatpulse.sh "${pkgdir}/usr/bin/whatpulse"
+ install -Dm755 sfs/usr/bin/whatpulse "${pkgdir}/usr/lib/whatpulse/whatpulse"
# Qt6
find sfs/usr/lib -type f -exec install -Dm644 -t "${pkgdir}/usr/lib/whatpulse/lib" '{}' +
# Qt6 plugins
@@ -71,7 +75,7 @@ package() {
# Set capabilities so that whatpulse can monitor network traffic
# Disable network monitor caps to prevent segfaults
- # setcap cap_net_raw,cap_net_admin=eip "${pkgdir}/usr/bin/whatpulse"
+ # setcap cap_net_raw,cap_net_admin=eip "${pkgdir}/usr/lib/whatpulse/whatpulse"
# Generate and install icons
for size in 16 20 22 24 28 32 36 44 48 64 72 96 128 150 192 256 310 384 512 1024; do