summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 56fe821b9a27..f6914c3f0bb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,25 @@
pkgname=whatsapp-for-linux
pkgver=1.0.8
-pkgrel=1
+pkgrel=2
pkgdesc="An unofficial WhatsApp linux client desktop application."
url="https://github.com/eneshecan/whatsapp-for-linux"
arch=(x86_64 aarch64)
license=(GPL)
depends=(gtkmm3 webkit2gtk nuspell hspell libvoikko aspell gst-plugins-base)
-makedepends=(git cmake)
+makedepends=(cmake)
provides=(whatsapp-for-linux)
conflicts=(whatsapp-for-linux)
-source=("git+https://github.com/eneshecan/whatsapp-for-linux")
-sha256sums=('SKIP')
-
-pkgver() {
- cd "$srcdir/$pkgname"
- cmake . > /dev/null
- cat "src/VERSION"
-}
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+md5sums=('56d86e321e4d1acc569bb9c32ff79a22')
build() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
cmake -DCMAKE_BUILD_TYPE=Release .
make
}
package() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
}