summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e8ff73dcf05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Fernando Cladera <fcladera [at] fcladera [dot] com>
+
+pkgname=whereami
+pkgver=0.2.29
+pkgrel=1
+pkgdesc="Uses WiFi signals and machine learning to predict where you are"
+url='https://github.com/kootenpv/whereami'
+arch=('any')
+license=('MIT')
+depends=('python' 'python-access_points' 'python-tqdm' 'python-scikit-learn')
+source=('https://pypi.python.org/packages/82/54/ce860ee6a4af80dd2bf52b58e6852be33d484536b44a86b9bfc22416b651/'$pkgname'-'$pkgver'.tar.gz#')
+md5sums=('6d965a0049db9daf5bbf6526caa10ab9')
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}