summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d1ccc6276cc..dc9ff981cb84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,6 +29,9 @@ makedepends=(
'git'
'python2-gobject2'
)
+checkdepends=(
+ 'python2-twisted'
+ )
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}" 'morituri')
source=("git+${url}.git")
@@ -40,6 +43,11 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+check() {
+ cd "$srcdir/${pkgname%-git}"
+ python2 -m unittest discover
+}
+
package() {
cd "$srcdir/${pkgname%-git}"
python2 setup.py install --root="${pkgdir}"/ --optimize=1