summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3192ae96a6dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: wenLiangcan <boxeed at gmail dot com>
+
+_pkgname=whoneeds
+pkgname=${_pkgname}-git
+pkgver=r5.1593694
+pkgrel=1
+pkgdesc="A fast whoneeds implemention in Python for Arch Linux"
+arch=('any')
+url="https://gist.github.com/lilydjwg/69111965e237fdb67d1378703173709f"
+license=('unkown')
+depends=('python' 'pyalpm')
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+source=("${_pkgname}"::'git+https://gist.github.com/69111965e237fdb67d1378703173709f.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+}
+