summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e61965852276
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: dreieck
+
+_pkgname="widelands-maps-rttr"
+pkgname="${_pkgname}"
+pkgdesc="Makes the maps installed by the Settlers II-remake 'Return to the Roots' available to play with widelands."
+url='http://siedler25.org/'
+arch=('any')
+pkgver=a
+pkgrel=1
+depends=('return-to-the-roots')
+makedepends=('return-to-the-roots') # Needed for pkgver()
+optdepends=('widelands: To play the maps with widelands.')
+provides=()
+conflicts=()
+replaces=("${_pkgname}-localver")
+license=('GPL2')
+options+=('emptydirs')
+source=()
+sha256sums=()
+
+pkgver() {
+ # Set the pkgver to that of the installed return-to-the-root.
+ pacman -Q return-to-the-roots | awk '{print $2}' | sed 's|-.*||'
+}
+
+package() {
+ install -d -v -m755 "${pkgdir}/usr/share/widelands/maps"
+ ln -svr "${pkgdir}/usr/share/s25rttr/RTTR/MAPS" "${pkgdir}/usr/share/widelands/maps/Return to the Roots-maps"
+}