summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 27 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1e8bf5ff8b68..abb2e05ba2e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,46 @@
# Maintainer : lsf <lsf@lsf>
pkgname=wifite2-git
-pkgver=r492.29803917c
+pkgver=r493.6fd209102
pkgrel=2
pkgdesc="A tool to attack multiple WEP and WPA encrypted networks at the same time"
arch=(any)
url="https://github.com/kimocoder/wifite2"
-license=('GPL')
-depends=(python aircrack-ng wireless_tools net-tools
- wireshark-cli python-argparse python-chardet)
+license=('GPL2')
+depends=(python aircrack-ng iw iproute2 net-tools
+ python-argparse python-chardet)
# scapy: listed in requirements.txt, but not actually used atm
-optdepends=(macchanger reaver bully
- cowpatty pyrit hcxdumptool
- hcxtools john hashcat)
+optdepends=(
+ 'wireshark-cli: detecting WPS networks and inspecting handshake capture files'
+ 'reaver: WPS Pixie-Dust & brute-force attacks'
+ 'bully: WPS Pixie-Dust & brute-force attacks'
+ 'cowpatty: detect WPA handshakes'
+ 'pyrit: detect WPA handshakes'
+ 'macchanger: change MAC for attacks'
+ 'hashcat: cracking PMKID hashes'
+ 'john: cracking PMKID hashes'
+ 'hcxdumptool: capturing PMKID hashes'
+ 'hcxtools: converting PMKID packet captures into hashcat format' # should be part of hcxtools?
+)
+ # 'hcxpcapngtool: converting PMKID packet captures into hashcat format' # should be part of hcxtools?
makedepends=(git)
source=($pkgname::git+https://github.com/kimocoder/wifite2.git)
-
sha256sums=('SKIP')
+provides=('wifite')
+conflicts=('wifite')
pkgver() {
cd "$pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build(){
+prepare() {
+ cd "$pkgname"
+ sed 's|sbin|bin|g' -i setup.cfg
+}
+
+
+build() {
cd "$pkgname"
python setup.py build
}
@@ -31,5 +48,5 @@ build(){
package() {
cd "$pkgname"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- mv ${pkgdir}/usr/sbin ${pkgdir}/usr/bin
+ install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
}