summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 62 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88c1b1eb24dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Wildfly Application Server package
+# Maintainer: Zdenek Obst <zdenek dot obst at gmail dot com>
+
+pkgname=wildfly-devel
+pkgver=9.0.0.CR1
+pkgrel=1
+
+pkgdesc='Wildfly Application Server'
+arch=('any')
+url='http://www.wildfly.org/'
+license=('LGPL')
+depends=('java-runtime>=7')
+conficts=('wildfly')
+
+_pkgloc=opt
+backup=(etc/profile.d/${pkgname}.sh
+ ${_pkgloc}/${pkgname}/domain/configuration/application-roles.properties
+ ${_pkgloc}/${pkgname}/domain/configuration/application-users.properties
+ ${_pkgloc}/${pkgname}/domain/configuration/logging.properties
+ ${_pkgloc}/${pkgname}/domain/configuration/mgmt-groups.properties
+ ${_pkgloc}/${pkgname}/domain/configuration/mgmt-users.properties
+ ${_pkgloc}/${pkgname}/domain/configuration/domain.xml
+ ${_pkgloc}/${pkgname}/domain/configuration/host.xml
+ ${_pkgloc}/${pkgname}/standalone/configuration/application-roles.properties
+ ${_pkgloc}/${pkgname}/standalone/configuration/application-users.properties
+ ${_pkgloc}/${pkgname}/standalone/configuration/logging.properties
+ ${_pkgloc}/${pkgname}/standalone/configuration/mgmt-groups.properties
+ ${_pkgloc}/${pkgname}/standalone/configuration/mgmt-users.properties
+ ${_pkgloc}/${pkgname}/standalone/configuration/standalone.xml
+ ${_pkgloc}/${pkgname}/bin/add-user.properties
+ ${_pkgloc}/${pkgname}/bin/appclient.conf
+ ${_pkgloc}/${pkgname}/bin/domain.conf
+ ${_pkgloc}/${pkgname}/bin/jboss-cli-logging.properties
+ ${_pkgloc}/${pkgname}/bin/jboss-cli.xml
+ ${_pkgloc}/${pkgname}/bin/standalone.conf)
+install=${pkgname}.install
+source=(http://download.jboss.org/wildfly/${pkgver}/wildfly-${pkgver}.tar.gz
+ ${pkgname}.service
+ ${pkgname}.sh
+ ${pkgname}.install
+ systemd-wrapper.sh)
+sha256sums=('c07409743d3ff64faf29bddda0aaf60b832c3ecb2b1ee11f6531dbc47e3b3371'
+ '916649a9d8bd4d42134dff6e3b6c2a5804a37eecb3814a3d7f677a7e3c05ebab'
+ '108380f6f8df229c5ccaac2e20f91fc37ca48867cff788af64bb64f47ad3b7b7'
+ '45396c8765efe3399f7fc977fd6c6066067cf4eff730086fd2e41a05ffebdec8'
+ '2087b8902fac7ad6ea5ebf3fd9653f1ac74147cee08580aae18cf609dfdb5064')
+
+package() {
+ cd "${srcdir}/wildfly-${pkgver}"
+ rm -f bin/*.{bat,exe}
+ install -dm755 ${pkgdir}/${_pkgloc}
+ cp -R ${srcdir}/wildfly-${pkgver} ${pkgdir}/${_pkgloc}/${pkgname}
+
+ # Prepare systemd service file
+ install -Dm755 ${srcdir}/${pkgname}.service ${pkgdir}/usr/lib/systemd/system/${pkgname}.service
+
+ # Prepare file for environment variables to profile.d
+ install -Dm755 ${srcdir}/${pkgname}.sh ${pkgdir}/etc/profile.d/${pkgname}.sh
+
+ # Include wrapper script for systemd startup
+ install -Dm755 ${srcdir}/systemd-wrapper.sh ${pkgdir}/${_pkgloc}/${pkgname}/bin/systemd-wrapper.sh
+}