summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 9 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 01efc5cedc91..2550c5d96974 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,27 @@
# Maintainer: Spike29 <leguen.yannick@gmail.com>
# Contributor: SpepS <dreamspepser at yahoo dot it>
-_pkg='wiLink'
pkgname='wilink'
-pkgver='2.4.2'
-pkgrel='4'
+pkgver='2.4.906'
+pkgrel='1'
pkgdesc='Instant messaging client and SIP softphone for Wifirst customers'
arch=('i686' 'x86_64')
url='https://github.com/jlaine/wilink'
license=('GPL3')
-depends=('libmad' 'libvorbis' 'libxss' 'qxmpp' 'qdjango' 'libnotify' 'libgnome-keyring' 'libgphoto2')
-makedepends=('cmake>=2.8.2')
+depends=('libxss' 'qxmpp' 'qt5-multimedia' 'qt5-x11extras' 'qt5-quickcontrols' 'qt5-webkit' 'desktop-file-utils' 'hicolor-icon-theme')
install="$pkgname.install"
-source=("https://download.wifirst.net/public/${_pkg}-${pkgver}.tar.bz2"
- "link-X11.patch")
-sha1sums=('a4c826c0a70c3ca0dcd953a2474f0ea576d0f9b1'
- '42b07fdca0a26fe4e2c34c53b50158c60536266e')
+source=("https://github.com/jlaine/${pkgname}/archive/v${pkgver}.tar.gz")
+sha1sums=('60f912e2ae958e6b7e809a57e08d4a3a57d36ed6')
build() {
- cd "$scrdir"
-
- # patching src/app/CMakeLists to solve an issue with an unlinked X11 library
- patch -p0 -i link-X11.patch
-
- # building
- cd "$_pkg-$pkgver/"
+ cd "$srcdir/$pkgname-$pkgver/"
[ -d build ] || mkdir build && cd "build/"
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ qmake-qt5 PREFIX=/usr WILINK_SYSTEM_QXMPP=1 ..
make
}
package() {
# installing
- cd "$srcdir/$_pkg-$pkgver/build/"
- make DESTDIR="$pkgdir/" install
-
- # setting up higher resolution icon
- rm "$pkgdir/usr/share/pixmaps/$_pkg.xpm"
- install -Dm644 ../src/data/images/128x128/$_pkg.png \
- "$pkgdir/usr/share/pixmaps/$_pkg.png"
+ cd "$srcdir/$pkgname-$pkgver/build/"
+ make INSTALL_ROOT="$pkgdir/" install
}