aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 21 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a90052d09f14..5207c692641f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,33 @@
-# Maintainer: Harsha Kuchampudi <harshakuchampudi@gmail.com>
+##########################################################################
+# Maintainer: Harsha Kuchampudi <harshakuchampudi AT gmail DOT com>
+# Github: https://github.com/hkuchampudi/Windscribe
+# Updated: 2018-04-04
+##########################################################################
+
pkgname=windscribe-cli
-pkgver=1.0
-pkgrel=4
-pkgdesc="Port of Windscribe's VPN command line interface"
-arch=('x86_64')
+pkgver=1.1
+pkgrel=1
+pkgdesc="Port of Windscribe's command line interface"
+arch=('x86_64' 'i686' 'armv6h' 'armv7h')
url="https://windscribe.com/"
license=('GPL-2+')
depends=('openvpn')
+optdepends=('stunnel')
replaces=('windscribe-cli')
install="windscribe-cli.install"
-source=("$pkgname_$pkgver_all.deb::https://windscribe.com/install/desktop/linux_deb")
-sha256sums=('9b173b1548c04524861839ff6c2e49a2a0e6143e7438cf5f5a784301010d15d1')
+source_armv6h=("${pkgname}_${pkgver}_${pkgrel}.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_${pkgver}-${pkgrel}_armhf.deb")
+source_armv7h=("${pkgname}_${pkgver}_${pkgrel}.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_${pkgver}-${pkgrel}_armhf.deb")
+source_i686=("${pkgname}_${pkgver}_${pkgrel}.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_${pkgver}_x86.deb")
+source_x86_64=("${pkgname}_${pkgver}_${pkgrel}.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_${pkgver}_x64.deb")
+sha256sums_armv6h=('2fcf951dab5c70877660c49beb2ce35c7f1b1df47c33caa471ea0cd96f58284c')
+sha256sums_armv7h=('2fcf951dab5c70877660c49beb2ce35c7f1b1df47c33caa471ea0cd96f58284c')
+sha256sums_i686=('049d8cf2231a50e43ed9c68f866219eb9d7604936ac1b9f4fdaeed3dedef4108')
+sha256sums_x86_64=('3639313f36bc16a200ce31e2c2d5c3e4f555189d9ab2d8d6acd376ed33dea180')
package() {
# Extract the debian package
echo "Extracting debian package"
- ar vx $srcdir/$pkgname_$pkgver_all.deb
+ ar vx $srcdir/${pkgname}_${pkgver}_${pkgrel}.deb
mkdir $srcdir/data
mkdir $srcdir/control
tar xf "data.tar.xz" -C "${srcdir}/data"
@@ -60,4 +72,4 @@ package() {
cp -r "${srcdir}/data/usr/" "${pkgdir}/"
chmod 0755 "${pkgdir}/usr/bin/windscribe"
chmod 0755 -R "${pkgdir}/usr/share/doc/windscribe-cli"
-} \ No newline at end of file
+}