summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 13 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e186b2ea68c..b98e1d25484e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,39 +6,32 @@
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Manuel Reimer <manuel.reimer@gmx.de>
-# Some documentation:
-# Bug with "patchset v1": https://bugs.winehq.org/show_bug.cgi?id=45327
-# Bug with "Version 8.15 fix": https://bugs.winehq.org/show_bug.cgi?id=45550
-# Bug with ntdll-futex problems: https://bugs.winehq.org/show_bug.cgi?id=45558
+# This PKGBUILD actually creates a build of wine-staging 3.14
+# No additional patches are applied!
+# Serves me as temporary solution until Arch Linux updates wine-staging
pkgname=wine-staging-lol
-pkgver=3.13
-_wsgitver=1de1a96f1e0dca5d012c807b4719b2f03b5f71c9
-pkgrel=3
+pkgver=3.14
+_winever=3.14
+pkgrel=1
_pkgbasever=${pkgver/rc/-rc}
-source=(https://dl.winehq.org/wine/source/3.x/wine-$_pkgbasever.tar.xz{,.sign}
- "wine-staging-g$_wsgitver.tar.gz::https://github.com/wine-staging/wine-staging/archive/$_wsgitver.tar.gz"
- "wine-staging-lol-patchset-v1.zip::https://bugs.winehq.org/attachment.cgi?id=61944"
- "wine-staging-lol-8.15-crash-fix.diff::https://bugs.winehq.org/attachment.cgi?id=61968"
- "wine-staging-back-out-ntdll-futex-condition-var.diff"
+source=(https://dl.winehq.org/wine/source/3.x/wine-$_winever.tar.xz{,.sign}
+ "wine-staging-v$_pkgbasever.tar.gz::https://github.com/wine-staging/wine-staging/archive/v$_pkgbasever.tar.gz"
harmony-fix.diff
30-win32-aliases.conf
wine-binfmt.conf)
-sha512sums=('a07a3d2a19261f9251f165ca4c14871e6ebda4d3f99da16f9fc41f06e80cae3fb50aeab96628c7a739e635e896dbb31c55df8b42c4637a058f9035c664c93a59'
+sha512sums=('50dbbf8a832abfa01247b9d170c6e1fe4f722cc8868659512df7bc17efd7e9d618db10283baf1eda0f1e4abbcdd130be16dbdb8d5a91b155c2c441e50e2b43f1'
'SKIP'
- 'e477dd6d152f6f2802dd041427be1a7407616d69c7d9e9d6397bac7498ac3473d15e468750996e4796dac17c87be585be607fff91d7fc49313e4b9adcfd25488'
- '45e29d664787c5a820902f99daef63c78f07c8c01c19ac9e9e720e471322571e46792db2d073d3a461c7f48df71c383065a366a8b746629a5c6f70b215cddac6'
- 'd53304d7352480fa66d116f9c38cab58e502bf0e4a65f375cea603301e88027308dbe734768460f212f44dba4979db0ff6871a6dccfa9fe032cd67264acdbd25'
- '526506092178fbeae16b6a0c2838a188a5451987f86e2bb8b2cd8e56a2a925164389f88361858747dcd7c32cec73161e5a88a9a8d51dba68b64db73d21207cdc'
+ 'f998baac6be3fece1ae6d4e924f883befea43f849d678c987e9fe4d102cf22fde7b4a0fa728294c46d70c7d29caa037022fb9e33ce4b4fac0e49c94d25cdfa66'
'b86edf07bfc560f403fdfd5a71f97930ee2a4c3f76c92cc1a0dbb2e107be9db3bed3a727a0430d8a049583c63dd11f5d4567fb7aa69b193997c6da241acc4f2e'
'6e54ece7ec7022b3c9d94ad64bdf1017338da16c618966e8baf398e6f18f80f7b0576edf1d1da47ed77b96d577e4cbb2bb0156b0b11c183a0accf22654b0a2bb'
'bdde7ae015d8a98ba55e84b86dc05aca1d4f8de85be7e4bd6187054bfe4ac83b5a20538945b63fb073caab78022141e9545685e4e3698c97ff173cf30859e285')
validpgpkeys=(5AC1A08B03BD7A313E0A955AF5E6E9EEB9461DD7
DA23579A74D4AD9AF9D3F945CEFAC8EAAF17519D)
-pkgdesc="A compatibility layer for running Windows programs - Staging branch with LoL fixes"
+pkgdesc="A compatibility layer for running Windows programs - Staging branch"
url="http://www.wine-staging.com"
arch=(x86_64)
options=(staticlibs)
@@ -123,13 +116,10 @@ install=wine.install
prepare() {
# Allow ccache to work
- mv wine-$_pkgbasever $pkgname
-
- # LOL Patches wine-staging
- patch -d wine-staging-$_wsgitver -p1 -i "$srcdir/wine-staging-back-out-ntdll-futex-condition-var.diff"
+ mv wine-$_winever $pkgname
# apply wine-staging patchset
- pushd wine-staging-$_wsgitver/patches
+ pushd wine-staging-$_pkgbasever/patches
./patchinstall.sh DESTDIR="$srcdir/$pkgname" --all
popd
@@ -139,13 +129,6 @@ prepare() {
patch -d $pkgname -Np1 < harmony-fix.diff
- # LOL Patches wine (after wine-staging patching)
- patch -d $pkgname -p1 -i "$srcdir/0003-Pretend-to-have-a-wow64-dll.patch"
- patch -d $pkgname -p1 -i "$srcdir/0006-Refactor-LdrInitializeThunk.patch"
- patch -d $pkgname -p1 -i "$srcdir/0007-Refactor-RtlCreateUserThread-into-NtCreateThreadEx.patch"
- patch -d $pkgname -p1 -i "$srcdir/0009-Refactor-__wine_syscall_dispatcher-for-i386.patch"
- patch -d $pkgname -p1 -i "$srcdir/wine-staging-lol-8.15-crash-fix.diff"
-
sed 's|OpenCL/opencl.h|CL/opencl.h|g' -i $pkgname/configure*
# Get rid of old build dirs