summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 72bc51f381c0..fcfccef105b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,23 @@
pkgname=wingide
_wingver=6.0.2
_wingrel=1
-_wing_patch_lvl=2 #bump this when adding a patch
+_wing_patch_lvl=3 #bump this when adding a patch
pkgver=$_wingver.$_wingrel.$_wing_patch_lvl
pkgrel=1
pkgdesc="Wing IDE Professional is the full-featured Python IDE for professional programmers."
url="http://www.wingware.com"
license=('custom')
arch=('x86_64')
-_wingpatch=("dont-fill-database-6.0.2p3-all.tar" "fix-remote-debug-6.0.2p1-all.tar" "py3-pi-files-6.0.2p2-linux64.tar")
+_wingpatch=("fix-debug-ipython-6.0.2p6-all.tar" "fix-cpu-usage-6.0.2p5-all.tar" "fix-none-module-6.0.2p4-all.tar" "dont-fill-database-6.0.2p3-all.tar" "fix-remote-debug-6.0.2p1-all.tar" "py3-pi-files-6.0.2p2-linux64.tar")
_patch_url_prefix=http://wingware.com/pub/$pkgname/$_wingver/patches/
_wingpatch=( "${_wingpatch[@]/#/$_patch_url_prefix}" )
source=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-x86_64-linux.tar.bz2" ${_wingpatch[*]})
depends=('hicolor-icon-theme' 'libpng' 'python2' 'xdg-utils')
options=(!strip !emptydirs)
md5sums=('e3d7ba6435b747ac348166d7db5aef00'
+ '2b0b5360a808e675dbd367ce68a20c04'
+ '30fa111b03ed2582872b10132cf232b5'
+ 'd534f8fc73390b92fa0f30dbe4da626e'
'b084f0bdbc2f4c250683f776f29d0ebc'
'18df10d42f3e7befd012db2c41c5a03f'
'03046d03198fe1535e24735ef6a8bd0e')