summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 9 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 88d67b29f20a..7d4cbf818234 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,27 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=wingide
-_wingver=6.0.5
+_wingver=6.0.6
_wingrel=1
-_wing_patch_lvl=4 #bump this when adding a patch
+_wing_patch_lvl=1 #bump this when adding a patch
pkgver=$_wingver.$_wingrel.$_wing_patch_lvl
pkgrel=1
pkgdesc="Wing IDE Professional is the full-featured Python IDE for professional programmers."
url="http://www.wingware.com"
license=('custom')
arch=('x86_64')
-_wingpatch=("fix-auto-arg-removal-6.0.5p1-all.tar" "fix-script-print-encoding-6.0.5p2-all.tar" "fix-logging-6.0.5p3-all.tar" "fix-remote-bps-6.0.5p4-all.tar" "fix-vi-mode-yy-6.0.5p5-all.tar" "fix-vi-mode-line-pos-6.0.5p6-all.tar" "fix-reverse-ssh-6.0.5p7-all.tar" "fix-auto-indent-6.0.5p8-all.tar" "fix-special-env-6.0.5p9-all.tar" "fix-indent-button-6.0.5p10-all.tar")
+_wingpatch=("longer-arm-timeout-6.0.6p1-all.tar" "longer-ssh-timeout-6.0.6p2-all.tar" "fix-remote-probe-6.0.6p3-all.tar" "avoid-remote-overwrite-6.0.6p4-all.tar" "fix-open-remote-sh-6.0.6p6-all.tar")
_patch_url_prefix=http://wingware.com/pub/$pkgname/$_wingver/patches/
_wingpatch=( "${_wingpatch[@]/#/$_patch_url_prefix}" )
source=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-x86_64-linux.tar.bz2" ${_wingpatch[*]})
depends=('hicolor-icon-theme' 'libpng' 'python2' 'xdg-utils')
options=(!strip !emptydirs)
-md5sums=('944c2edf81b7a681a9d0ab5dc528498c'
- '5c6ac15d903a67a3c2f62d8720ea7c25'
- '25ae8c72354f4798c7bb871d45bedb37'
- '117eec0e2ed0d062fcddbb9484170f53'
- '3a841c186a0c1f850acd5463c2f612b8'
- 'aa5edf6eb1259b04def4a989632cf2ca'
- '4be37a3ad346059fe4b6f2b522004a99'
- '2da3c2dd61721328ea84978f2c65e690'
- '4b672bbc005297e2cc8edb33df175601'
- '87262383b43bde9ad010aef1eafd1619'
- '547e3b3688cbd7ee245626e85063e000')
+md5sums=('5df65a288d6c3bcb448cfe0d1a250385'
+ '78cb37932cb1e98ce81bbd6dfedbd985'
+ 'eb7bcac8b4872989ce75f148740014de'
+ '6ac113b4795e8eb2c2a863509d48d581'
+ '40184285482d23ddb7733c1031e96ffd'
+ '03272860abe8e7418df14e04e2bc2e3a')
install=${pkgname}.install