summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 8 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a21ba15967e9..712ce29cc443 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=wingide
-_wingver=5.1.11
+_wingver=5.1.12
_wingrel=1
-pkgver=$_wingver.$_wingrel
-pkgrel=2
-epoch=3 #bump this when adding a new patch
+_wing_patch_lvl=1
+pkgver=$_wingver.$_wingrel.$_wing_patch_lvl
+pkgrel=1
pkgdesc="Wing IDE Professional is the full-featured Python IDE for professional programmers."
url="http://www.wingware.com"
license=('custom')
arch=('i686' 'x86_64')
[ "$CARCH" = 'i686' ] && _pkgarch=i386
[ "$CARCH" = 'x86_64' ] && _pkgarch=x86_64
-_wingpatch_x86_64=("fix-autoclose-5.1.11p1-all.tar" "fix-nonpy-indent-5.1.11p2-all.tar" "all-classes-5.1.11p3-all.tar")
-_wingpatch_i686=("fix-autoclose-5.1.11p1-all.tar" "fix-nonpy-indent-5.1.11p2-all.tar" "all-classes-5.1.11p3-all.tar")
+#_wingpatch_x86_64=("fix-autoclose-5.1.11p1-all.tar" "fix-nonpy-indent-5.1.11p2-all.tar" "all-classes-5.1.11p3-all.tar")
+#_wingpatch_i686=("fix-autoclose-5.1.11p1-all.tar" "fix-nonpy-indent-5.1.11p2-all.tar" "all-classes-5.1.11p3-all.tar")
_patch_url_prefix=http://wingware.com/pub/$pkgname/$_wingver/patches/
if [[ ! -z "$_wingpatch_x86_64" ]]; then
_wingpatch_x86_64=( "${_wingpatch_x86_64[@]/#/$_patch_url_prefix}" )
@@ -25,14 +25,8 @@ source_x86_64=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_
source_i686=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-i386-linux.tar.gz" ${_wingpatch_i686[*]})
depends=('hicolor-icon-theme' 'libpng' 'python2' 'xdg-utils')
options=(!strip !emptydirs)
-md5sums_i686=('392b8f3a0e2dcb69fd2d8316bd88b028'
- 'fd1b66865a42b27fd6344b71e747c654'
- 'ec4937a0b3fc32f553d7ea9d65cf11d9'
- 'bf9cf9df754f06cb8d7fe9d056fa8d7e')
-md5sums_x86_64=('ddacf06b4cc9577b9b80cbbb79de2d32'
- 'fd1b66865a42b27fd6344b71e747c654'
- 'ec4937a0b3fc32f553d7ea9d65cf11d9'
- 'bf9cf9df754f06cb8d7fe9d056fa8d7e')
+md5sums_i686=('6d3e20447ea2b772e4da38bf02c81031')
+md5sums_x86_64=('52b7f26a71e2a1ea9cbb51ade7181825')
install=${pkgname}.install
prepare() {