summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 486340daa65f..b8eb0793ba34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,23 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=wingide
-_wingver=6.1.2
+_wingver=6.1.4
_wingrel=1
-_wing_patch_lvl=3 #bump this when adding a patch
+_wing_patch_lvl=1 #bump this when adding a patch
pkgver=$_wingver.$_wingrel.$_wing_patch_lvl
pkgrel=1
pkgdesc="Wing IDE Professional is the full-featured Python IDE for professional programmers."
url="http://www.wingware.com"
license=('custom')
arch=('x86_64')
-
-_wingpatch=("fix-new-venv-6.1.2p1-all.tar" "fix-goto-defn-6.1.2p4-all.tar" "fix-activation-6.1.2p2-all.tar" "fix-sassist-links-6.1.2p6-all.tar" "fix-autocomplete-lockup-6.1.2p7-all.tar")
+_wingpatch=("fix-find-symbol-6.1.4p1-all.tar")
_patch_url_prefix=http://wingware.com/pub/$pkgname/$_wingver/patches/
_wingpatch=( "${_wingpatch[@]/#/$_patch_url_prefix}" )
source=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-x86_64-linux.tar.bz2" ${_wingpatch[*]})
depends=('hicolor-icon-theme' 'libpng' 'python2' 'xdg-utils')
options=(!strip !emptydirs)
-md5sums=('c64255d62885498ac20513cafd7527c3'
- 'cf1a2166c7a3605264d22269b346fb7d'
- 'd691d2b46be9d0723b2c9742b89f9506'
- '67f6cf80f5b8031a6ace081b38e28286'
- '2e337be8917cbd6d7692f974c95888ad'
- '67926f2b3ad03cde727f66078455e8b7')
+md5sums=('1a0007a298152cb8a9454534c6af21c9'
+ '0425c50fecff2fdfa1e41addc13ce825')
install=${pkgname}.install