summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD60
1 files changed, 31 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c3ca723dce3..0d8998d8b22c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,44 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=wingpanel-indicator-sound
-pkgver=2.0.5
-pkgrel=2
+pkgver=2.1.2
+pkgrel=1
pkgdesc='Wingpanel Sound Indicator'
-arch=('i686' 'x86_64')
+arch=(x86_64)
url='https://github.com/elementary/wingpanel-indicator-sound'
-license=('GPL3')
-groups=('pantheon')
-depends=('cairo' 'gdk-pixbuf2' 'glib2' 'glibc' 'gtk3' 'libcanberra' 'libgee'
- 'libnotify' 'libpulse'
- 'libgranite.so' 'libwingpanel-2.0.so')
-makedepends=('cmake' 'gobject-introspection' 'gtk2' 'intltool' 'vala' 'wingpanel')
-source=("wingpanel-indicator-sound-${pkgver}.tar.gz::https://github.com/elementary/wingpanel-indicator-sound/archive/${pkgver}.tar.gz")
-sha256sums=('680617e07ec4fc6b0c21f028b12a7cd4a2cb6fcc387f67c5ac73bb8545fd0f80')
-
-prepare() {
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build
-}
+license=(GPL3)
+groups=(pantheon)
+depends=(
+ cairo
+ gdk-pixbuf2
+ glib2
+ gtk3
+ libcanberra
+ libgee
+ libgranite.so
+ libnotify
+ libpulse
+ libwingpanel-2.0.so
+)
+makedepends=(
+ git
+ gobject-introspection
+ gtk2
+ intltool
+ meson
+ vala
+ wingpanel
+)
+source=(wingpanel-indicator-sound::git+https://github.com/elementary/wingpanel-indicator-sound.git#tag=${pkgver})
+sha256sums=(SKIP)
build() {
- cd build
-
- cmake ../wingpanel-indicator-sound-${pkgver} \
- -DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_INSTALL_LIBDIR='/usr/lib' \
- -DGSETTINGS_COMPILE='OFF'
- make
+ arch-meson wingpanel-indicator-sound build
+ ninja -C build
}
package() {
- cd build
-
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja -C build install
}
# vim: ts=2 sw=2 et: