summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a85648a99854..bd4b7fd7b3ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=wire-desktop-beta
_pkgname=${pkgname%-beta}
pkgver=3.5.2881
-pkgrel=2
+pkgrel=3
pkgdesc='End-to-end encrypted messenger with file sharing, voice calls and video conferences'
arch=('x86_64')
url='https://wire.com/'
@@ -19,11 +19,16 @@ sha256sums=('4216cd9c3a2c4920aec2f3c967181b04bfafdb1b47e526a8e823911cce704da1'
'79505a8ae908a26f74af3d72c24cb09815dc5688eca26ee4bbf57362a865d7c5')
prepare() {
+ # Ensure we compile native extensions against system electron version
+ local electronver="$(pacman -Q electron | cut -d' ' -f2 | cut -d'-' -f1)"
+ msg2 "Compiling against system electron version: $electronver"
+ sed -i 's/"electron": ".*"/"electron": "'"$electronver"'"/' "${_pkgname}-linux-${pkgver}/package.json"
+
# Create launcher script
cat << EOF > "${pkgname}"
#!/bin/sh
-electron "/usr/lib/${pkgname}"
+electron "/usr/lib/${pkgname}" "\$@"
EOF
}
@@ -31,13 +36,13 @@ build() {
cd "${_pkgname}-linux-${pkgver}"
yarn
yarn build:ts
- npx grunt 'linux-other-internal'
+ npx grunt 'clean:linux' 'update-keys' 'gitinfo' 'release-internal' 'bundle'
}
package() {
# Place files
install -d "${pkgdir}/usr/lib/${pkgname}"
- cp -a "${_pkgname}-linux-${pkgver}"/wrap/dist/linux-unpacked/resources/app/* "${pkgdir}/usr/lib/${pkgname}"
+ cp -a "${_pkgname}-linux-${pkgver}/electron"/* "${pkgdir}/usr/lib/${pkgname}"
# Place launcher script
install -Dm755 -t "${pkgdir}/usr/bin/" "${pkgname}"
@@ -52,10 +57,4 @@ package() {
# Spellcheck dictionaries
rm -rf "${pkgdir}/usr/lib/${pkgname}/node_modules/spellchecker/vendor/hunspell_dictionaries"
ln -s "/usr/share/hunspell" "${pkgdir}/usr/lib/${pkgname}/node_modules/spellchecker/vendor/hunspell_dictionaries"
-
- # Place license files
- local license
- for license in "LICENSE.electron.txt" "LICENSES.chromium.html"; do
- install -Dm644 "${_pkgname}-linux-${pkgver}/wrap/dist/linux-unpacked/${license}" "${pkgdir}/usr/share/licenses/${pkgname}/${license}"
- done
}