summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ad1597c7b06a..70afef0abac9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
-# Maintainer: Davide Depau <davide@depau.eu>
+# Contributor: Lex Black <autumn-wind@web.de>
+# Contributor: Davide Depau <davide@depau.eu>
_pkgname=wireguard-go
pkgname=${_pkgname}-git
-pkgver=v0.0.20191012.13.gddfad45
+pkgver=0.0.20220316.r9.gbb719d3
pkgrel=1
pkgdesc="Go userspace implementation of WireGuard"
arch=('i686' 'pentium4' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url="https://git.zx2c4.com/wireguard-go/"
license=('GPL')
makedepends=('go')
+conflicts=("${_pkgname}")
provides=("${_pkgname}" "wireguard")
source=("${_pkgname}::git+https://git.zx2c4.com/wireguard-go.git")
sha1sums=('SKIP')
+
pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --dirty 2>/dev/null | sed 's/-/./g'
+ cd "$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {