summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8938640680fb..005a23333e85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -54,6 +54,14 @@ pkgver() {
git describe --long --match=v\* | sed 's/^v//;s/-/+/g'
}
+prepare() {
+ cd "$srcdir/wireshark"
+
+ # For .desktop and icon files. https://code.wireshark.org/review/18708
+ git fetch https://code.wireshark.org/review/wireshark refs/changes/08/18708/1 &&
+ git cherry-pick --no-commit FETCH_HEAD
+}
+
build() {
cd "$srcdir/wireshark"
mkdir -p build