summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e14e3204dcba..0570c36e1f45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,23 @@
+# Maintainer: thyTwilightGoth <https://aur.archlinux.org/account/thyTwilightGoth>
+# Contributor: Pedro <https://aur.archlinux.org/account/PedroHLC>
+
pkgname=wlcs
-pkgver=1.1.0
-_tardirname=1.0.0
+pkgver=1.3.0
pkgrel=1
pkgdesc="Canonical's protocol-conformance-verifying test suite for Wayland compositor implementations."
url='https://github.com/MirServer/wlcs'
-arch=(x86_64 i686)
+arch=(x86_64 i686 aarch64)
license=(GPL)
depends=(gtest boost-libs wayland)
makedepends=(git cmake boost gmock wayland-protocols)
optdepends=()
-source=("https://github.com/MirServer/wlcs/releases/download/v${pkgver}/wlcs-${pkgver}.tar.xz")
-sha256sums=('7238dd4a0fece16b7eb21db90722795fb68f20e0fcfc82ab01bce5b63ca415d1')
+source=("git+https://github.com/MirServer/wlcs.git")
+sha256sums=('SKIP')
BUILD_DIR=build
build() {
- cd "${pkgname}-${_tardirname}"
+ cd "${pkgname}}"
mkdir -p "${BUILD_DIR}"
cd "${BUILD_DIR}"
cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr -DCMAKE_INSTALL_LIBDIR="lib/" ..
@@ -23,7 +25,7 @@ build() {
}
package() {
- cd "${pkgname}-${_tardirname}/${BUILD_DIR}"
+ cd "${pkgname}/${BUILD_DIR}"
make DESTDIR="${pkgdir}/" install
}