summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 20 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4a3893a5a36c..ebdcb7e388a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,32 @@
-# Maintainer: Robert Cegliński <rob.ceglinski@gmail.com>
+# maintainer: Sergey A. <murlakatamenka@disroot.org>
+# ex-maintainer: Robert Cegliński <rob.ceglinski@gmail.com>
# Contributor: Christopher Snowhill <chris@kode54.net>
# Contributor: Denis Zheleztsov <difrex.punk@gmail.com>
pkgname=wlr-randr
-pkgver=0.2.0
-pkgrel=1
-pkgdesc="A xrandr clone for wlroots compositors"
-arch=('x86_64')
-url="https://github.com/emersion/wlr-randr"
+pkgver=0.4.1
+pkgrel=2
+pkgdesc='Utility to manage outputs of a Wayland compositor'
+arch=('x86_64' 'aarch64')
+url='https://sr.ht/~emersion/wlr-randr'
+_url='https://git.sr.ht/~emersion/wlr-randr'
license=('MIT')
-depends=("wayland")
-makedepends=("meson" "ninja")
-source=("https://github.com/emersion/wlr-randr/releases/download/v$pkgver/wlr-randr-$pkgver.tar.gz"{,.sig})
-sha256sums=('e1b60992e41aebf733f13c2bdd2c70375fd3ddf7f0735bc4183858fda9c18e51'
- 'SKIP')
+depends=('wayland')
+makedepends=('meson')
+source=("$pkgname-$pkgver.tar.gz::${_url}/archive/v$pkgver.tar.gz")
+sha256sums=('8af085aeed3132f7442a05bafeadfd0ea30e9a4818af1a91e161f7d560f2cd93')
validpgpkeys=('34FF9526CFEF0E97A340E2E40FDE7BE0E88F5E48')
build() {
- arch-meson $pkgname-$pkgver build
- meson compile -C build
+ cd "$pkgname-v$pkgver"
+
+ arch-meson build
+ meson compile -C build
}
package() {
- DESTDIR="$pkgdir" meson install -C build
- install -Dm644 $pkgname-$pkgver/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$pkgname-v$pkgver"
+
+ meson install -C build --destdir "$pkgdir"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}