summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 43d28111157b..428ee3b043d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgname='wlroots-git'
-pkgver=r2505.7c2241a5
+pkgver=r2574.8585533a
pkgrel=1
license=('custom:MIT')
pkgdesc='Modular Wayland compositor library'
@@ -8,6 +8,7 @@ url='https://github.com/swaywm/wlroots'
arch=('x86_64')
provides=('wlroots')
conflicts=('wlroots')
+options=('debug' '!strip')
depends=('libcap' 'systemd' 'wayland' 'opengl-driver' 'libxcb'
'xcb-util-errors' 'xcb-util-image' 'xcb-util-wm' 'pixman'
'libinput' 'libxkbcommon')
@@ -30,12 +31,15 @@ build () {
rm -rf build
meson build \
--prefix /usr \
+ --buildtype debug \
-Denable-libcap=true \
-Denable-systemd=true \
-Denable-elogind=false \
-Denable-xcb_errors=true \
-Denable-xwayland=true \
- -Denable-x11_backend=true
+ -Denable-x11_backend=true \
+ -Denable-rootston=true \
+ -Denable-examples=true
ninja -C build
}