summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-x[-rw-r--r--]PKGBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f2fa6ad7d2ca..a22105d912e8 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer : Vincent Grande <shoober420@gmail.com>
# Contributor : Adrian Perez de Castro <aperez@igalia.com>
+# Contributor : Antonin Décimo <antonin dot decimo at gmail dot com>
# Contributor : Eric Vidal <eric@obarun.org>
# Contributor : Jean-Michel T.Dydak <jean-michel@obarun.org>
# Contributor : Brett Cornwall <ainola@archlinux.org>
# Contributor : Omar Pakker
pkgname=wlroots-strace-git
-pkgver=0.10.1
+pkgver=0.13.0
pkgrel=1
pkgdesc='Modular Wayland compositor library'
url="https://github.com/swaywm/wlroots"
@@ -17,21 +18,26 @@ sha512sums=('SKIP')
depends=(
'libinput'
+ 'libxcb'
'libxkbcommon'
'opengl-driver'
'pixman'
+ 'wayland'
'xcb-util-errors'
'xcb-util-image'
'xcb-util-wm'
'xcb-util-renderutil'
'xorg-xwayland'
+ 'seatd'
+ 'systemd'
)
makedepends=(
+ 'git'
'meson'
'ninja'
'wayland-protocols'
)
-provides=('libwlroots.so' 'wlroots' 'wlroots-git')
+provides=('libwlroots.so' 'wlroots' 'wlroots-git' "wlroots=${pkgver%%.r*}")
conflicts=('wlroots' 'wlroots-git')
pkgver () {
@@ -49,8 +55,7 @@ _path=(
_flags=(
--buildtype=debug
- -Dlogind=auto
- -Dlogind-provider=auto
+ -Dlibseat=auto
-Dxcb-errors=enabled
-Dxcb-icccm=enabled
-Dxcb-xkb=enabled
@@ -70,3 +75,8 @@ package() {
DESTDIR="$pkgdir" ninja $NINJAFLAGS -C build install
install -Dm644 "wlroots/LICENSE" -t "$pkgdir/usr/share/licenses/wlroots/"
}
+
+post_upgrade() {
+ echo "Make sure to upgrade wlroots-strace-git and sway-strace-git together."
+ echo "Upgrading one but not the other is unsupported."
+}