summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 10 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a573fda3e07b..82bb4f5509d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,33 +3,22 @@
pkgname=wmfrog
pkgdesc="A WindowMaker dock app for weather reports."
pkgver=0.3.1
-pkgrel=2
+pkgrel=1
arch=(i686 x86_64)
url="http://sourceforge.net/projects/wmfrog"
license=('GPL')
depends=('libxpm')
-source=("http://downloads.sourceforge.net/wmfrog/wmfrog-0.3.1.tgz"
- "debian-orig.patch"
- "20-weather.pl.patch"
- "weather.pl-new-line-skip.patch"
- "renamed-wmfrog.c.patch"
- "new-station-lookup-url.patch"
- "wmfrog.1.pod")
-md5sums=('3469ae5043a7bec538dff31b4a2397ea'
- '7b2fece308e94c6ba2281fae83ece24b'
- '95cb86928984baa7dfe5b5a8870efa09'
- 'f8872dc232a91aeaa465f9139068842c'
- '86e8eeb4b5508c30eab08e9f51964e53'
- '26315cb650d3f26fcd27dcac323f10b2'
- 'f16d84c6bc8ea9f432c5055d6354a9f8')
+source=("http://http.us.debian.org/debian/pool/main/w/wmfrog/wmfrog_0.3.1.orig.tar.gz"
+ "http://http.us.debian.org/debian/pool/main/w/wmfrog/wmfrog_0.3.1-1.debian.tar.xz")
+md5sums=('de4975f2c6a7931fdf5faa3c263aaf5f'
+ '94123f2791d8fc144502540d4273b8cf')
prepare() {
cd "${srcdir}"
- patch -Np1 -b -z .orig -i debian-orig.patch
- patch -Np1 -b -z .orig -i 20-weather.pl.patch
- patch -Np1 -b -z .orig -i weather.pl-new-line-skip.patch
- patch -Np1 -b -z .orig -i renamed-wmfrog.c.patch
- patch -Np1 -b -z .orig -i new-station-lookup-url.patch
+ patch -Np1 -b -z .orig -i debian/patches/20-weather.pl.patch
+ patch -Np1 -b -z .orig -i debian/patches/weather.pl-new-line-skip.patch
+ patch -Np1 -b -z .orig -i debian/patches/renamed-wmfrog.c.patch
+ patch -Np1 -b -z .orig -i debian/patches/new-station-lookup-url.patch
}
build() {
@@ -47,7 +36,7 @@ build() {
--nourls \
--release="$pkgname $pkgver" \
--section="1" \
- ../wmfrog.1.pod >wmfrog.1
+ ../debian/wmfrog.1.pod >wmfrog.1
}
package() {