summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd592244ac20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Caleb Johnson <me@calebj.io>
+_pkgname=wmidump
+pkgname=${_pkgname}-git
+provides=wmidump
+pkgrel=1
+pkgver=r13
+conflicts=wmidump
+pkgdesc="Dump WMI informations from ACPI tables"
+arch=('i686' 'x86_64')
+url="https://github.com/iksaif/wmidump"
+license=unknown
+depends=()
+makedepends=(git)
+source=("${pkgname}"::'git+http://github.com/iksaif/wmidump')
+sha256sums=('SKIP')
+
+pkgver(){
+ cd "${srcdir}/${pkgname}"
+ echo r`git rev-list --count HEAD`
+}
+
+build(){
+ cd "${srcdir}/${pkgname}"
+ make
+}
+
+package(){
+ cd "${srcdir}/${pkgname}"
+ install -Dm755 ${_pkgname} "${pkgdir}/usr/bin/${_pkgname}"
+}