summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 14 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7b5a5258a560..f98d288a51ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,26 @@
pkgname=wmrc
pkgver=1.1
-pkgrel=5
+pkgrel=6
pkgdesc='WMRC is a shell utility for extending window manager capabilities using modules with dependency and error checking.'
arch=('any')
url='https://github.com/filiparag/wmrc'
license=('MIT')
depends=('dash')
-makedepends=('git')
-source=('git+https://github.com/filiparag/wmrc.git')
-sha1sums=('SKIP')
-
-prepare() {
- cd "${pkgname}"
- git checkout "tags/${pkgver}"
-}
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('ee6bfdac42cc5d7e30e7af593ada869ce71a33a9cb8cc9bcb22040ac044c7bfc')
package() {
- cd "${pkgname}"
- install -Dm 755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- install -d -m 755 "${pkgdir}/usr/share/${pkgname}"
- install -Dm 644 "rc.conf" "${pkgdir}/usr/share/${pkgname}/"
- install -Dm 644 "usage.txt" "${pkgdir}/usr/share/${pkgname}/"
- install -Dm 644 "wmrc.man" "${pkgdir}/usr/share/man/man1/${pkgname}.${pkgver}"
+
+ cd "${pkgname}-${pkgver}"
+
+ install -Dm 755 -t "${pkgdir}/usr/bin/" "${pkgname}"
+
+ install -Dm 644 'wmrc.man' "${pkgdir}/usr/share/man/man1/${pkgname}.1"
+ install -Dm 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" 'LICENSE'
+ install -Dm 644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md'
+
+ install -Dm 644 -t "${pkgdir}/usr/share/${pkgname}" 'rc.conf' 'usage.txt'
cp -r --preserve=mode "modules" "${pkgdir}/usr/share/${pkgname}/"
+
} \ No newline at end of file