summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 15 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 51f2a86588ba..6eaa7097ec11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,38 +3,37 @@
# Contributor: Salvador PardiƱas <darkfm@vera.com.uy>
pkgname=woeusb
-pkgver=3.3.0
-pkgrel=2
+pkgver=3.3.1
+pkgrel=1
pkgdesc="A Linux program to create Windows USB stick installer from a Windows DVD or an image"
arch=('x86_64')
url="https://github.com/slacka/WoeUSB"
license=('GPL3')
depends=('wxgtk2' 'grub' 'dosfstools' 'parted' 'wget' 'ntfs-3g')
+makedepends=('git')
optdepends=('gksu')
conflicts=('woeusb-git')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/slacka/WoeUSB/archive/v$pkgver.tar.gz"
- "disable_writeback_workaround.patch")
-sha256sums=('dc0e1a233143a33182339915d043a419c089b8bfb0d3813b17acbff2bdb285bb'
- 'f051d9dbf1015596327b91abeea5c9f2404904e40e168f798fb4447e3fa9acb5')
+source=("WoeUSB-${pkgver}::git+https://github.com/slacka/WoeUSB.git#tag=v${pkgver}")
+sha256sums=('SKIP')
prepare() {
- cd "WoeUSB-$pkgver"
+ cd "WoeUSB-$pkgver"
- # Disable changing kernel cache behaviour, since it fails on newer versions
- # See https://github.com/slacka/WoeUSB/issues/267
- patch -Np1 -i "${srcdir}/disable_writeback_workaround.patch"
+ grep 'filter=version' .gitattributes | cut -d' ' -f1 | while read file; do
+ sed -i "s/@@WOEUSB_VERSION@@/${pkgver}/" $file
+ done
- autoreconf --install
- ./configure --prefix=/usr
+ autoreconf --install
+ ./configure --prefix=/usr
}
build() {
- cd "WoeUSB-$pkgver"
- make
+ cd "WoeUSB-$pkgver"
+ make
}
package() {
- cd "WoeUSB-$pkgver"
- make DESTDIR="$pkgdir/" install
+ cd "WoeUSB-$pkgver"
+ make DESTDIR="$pkgdir/" install
}