summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f42c1c62367a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Salvador PardiƱas <darkfm@vera.com.uy>
+pkgname=woeusb-git
+pkgver=r484.b67b343
+pkgrel=1
+pkgdesc="A Linux program to create Windows USB stick installer from a real Windows DVD or an image"
+arch=('x86_64')
+url="https://github.com/slacka/WoeUSB"
+license=('GPL3')
+groups=()
+depends=('webkitgtk2' 'wxgtk3')
+makedepends=('git')
+provides=("woeusb")
+conflicts=("")
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/slacka/WoeUSB.git')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/WoeUSB"
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/WoeUSB"
+ ./configure
+ make
+}
+
+package() {
+ cd "$srcdir/WoeUSB"
+ make DESTDIR="$pkgdir/" install
+ mv "$pkgdir/usr/local/share/man" "$pkgdir/usr/local/man"
+}