summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37373f7bf313..03a28082fee7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
pkgname=wofi-hg
-pkgver=r57.15a802c4f55f
+pkgver=r112.7906ded22800
pkgrel=1
pkgdesc="Rofi-like wlroots launcher"
arch=('x86_64')
url="https://hg.sr.ht/~scoopta/wofi"
license=('GPL3')
depends=('wayland' 'gtk3')
-makedepends=('mercurial')
+makedepends=('mercurial' 'meson')
source=("${pkgname}::hg+$url")
sha256sums=('SKIP')
pkgver() {
@@ -14,10 +14,11 @@ pkgver() {
printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
}
build() {
- cd "${pkgname}/Release"
- make
+ cd "${pkgname}"
+ meson build
+ ninja -C build
}
package() {
mkdir -p "$pkgdir/usr/bin"
- cp ${pkgname}/Release/wofi "$pkgdir/usr/bin/"
+ cp ${pkgname}/build/wofi "$pkgdir/usr/bin/"
} \ No newline at end of file