summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae181b987762
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: noobping <hello@noobping.dev>
+# Contributor: noobping <hello@noobping.dev>
+
+pkgname=wofi-pass
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="A Wayland-native interface for conveniently using pass"
+arch=('any')
+url='https://github.com/TinfoilSubmarine/wofi-pass'
+license=('GPL')
+depends=('coreutils' 'findutils' 'grep' 'man-pages' 'pass' 'tcl' 'util-linux' 'wl-clipboard' 'wofi' 'wtype')
+optdepends=('pass-otp: for OTP support')
+source=(https://raw.githubusercontent.com/purplg/wofi-pass/master/wofi-pass)
+sha512sums=('c47d7067dedc0038d75625ecd10a5b37560862cb4f6209b140951fb27dc2979245906dbbcd03e0fe9b35b1aafb3faf15d95b22a528df3a4143563aa302c3cc46')
+
+package() {
+ mkdir -p "$pkgdir"/usr/bin
+ install -m755 wofi-pass "$pkgdir"/usr/bin/wofi-pass
+}