summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 10 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea41a2f20b85..da41c8d8c397 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,23 @@
-# Maintainer: dacoit <dacoit at tuta.io>
+# Maintainer: Schroedinger <1181822466 at qq dot com>
+# Contributor: dacoit <dacoit at tuta.io>
# Contributor: Andreas B. Wagner <AndreasBWagner@pointfree.net>
# Contributor: Aaron Schaefer <aaron@elasticdog.com>
# Contributor: Evan Gates <evan.gates at gmail dot com>
# Contributor: Vardyr <vardyr.al at insocada dot com>
-
pkgname=woof
-pkgver=20120531
+pkgver=20200624
pkgrel=1
pkgdesc='An ad-hoc single file webserver; Web Offer One File'
arch=('any')
-url='http://www.home.unix-ag.org/simon/woof.html'
+url="http://www.home.unix-ag.org/simon/$pkgname.html"
license=('GPL2')
-depends=('python2')
-conflicts=('woof-python3')
-source=("http://www.home.unix-ag.org/simon/$pkgname")
-md5sums=('89081e64362421dcb683a19c10a15e59')
-
-prepare() {
- sed -i 's|^#!/usr/bin/env python$|#!/usr/bin/env python2|' "$pkgname"
-}
+depends=('python3')
+conflicts=()
+source=("git+https://github.com/simon-budig/$pkgname")
+md5sums=('SKIP')
package() {
+ cd "$srcdir/$pkgname"
install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
}