summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 15 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57618b17c72d..a91a56fb2d7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,28 @@
-# $Id: PKGBUILD 310007 2017-11-15 14:11:34Z foutrelis $
-# Maintainer: Thomas Bächler <thomas@archlinux.org>
+# Maintainer: Kewl <xrjy@nygb.rh.bet(rot13)>
+# Contributor: Thomas Bächler <thomas@archlinux.org>
pkgname=wpa_supplicant_gui
-pkgver=2.6
+_pkgname=${pkgname%_gui}
+pkgver=2.9
pkgrel=1
-pkgdesc="A Qt frontend to wpa_supplicant"
-url="http://hostap.epitest.fi/wpa_supplicant"
+pkgdesc="A Qt frontend for interacting with wpa_supplicant"
+url="https://w1.fi/wpa_supplicant/"
arch=('x86_64')
depends=('qt5-base' 'wpa_supplicant')
license=('GPL')
-source=("http://hostap.epitest.fi/releases/wpa_supplicant-$pkgver.tar.gz")
-sha256sums=('b4936d34c4e6cdd44954beba74296d964bc2c9668ecaa5255e499636fe2b1450')
+source=("https://w1.fi/releases/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('fcbdee7b4a64bea8177973299c8c824419c413ec2e3a95db63dd6a5dc3541f17')
build() {
- cd wpa_supplicant-${pkgver}/wpa_supplicant/wpa_gui-qt4
- qmake-qt5 QMAKE_CFLAGS_RELEASE="$CPPFLAGS $CFLAGS" QMAKE_CXXFLAGS_RELEASE="$CPPFLAGS $CXXFLAGS" QMAKE_LFLAGS_RELEASE="$LDFLAGS"
+ cd "${_pkgname}-${pkgver}/${_pkgname}/wpa_gui-qt4"
+ qmake-qt5 QMAKE_CFLAGS_RELEASE="${CPPFLAGS} ${CFLAGS}" QMAKE_CXXFLAGS_RELEASE="${CPPFLAGS} ${CXXFLAGS}" QMAKE_LFLAGS_RELEASE="${LDFLAGS}"
make
}
package() {
- cd wpa_supplicant-${pkgver}/wpa_supplicant/wpa_gui-qt4
- install -Dm755 wpa_gui "${pkgdir}/usr/bin/wpa_gui"
- install -Dm644 icons/wpa_gui.svg "${pkgdir}/usr/share/pixmaps/wpa_gui.svg"
- install -Dm644 wpa_gui.desktop "${pkgdir}/usr/share/applications/wpa_gui.desktop"
- install -Dm644 "${srcdir}/wpa_supplicant-${pkgver}/wpa_supplicant/doc/docbook/wpa_gui.8" \
- "${pkgdir}/usr/share/man/man8/wpa_gui.8"
+ cd "${_pkgname}-${pkgver}/${_pkgname}/wpa_gui-qt4"
+ install -Dm755 -t "${pkgdir}/usr/bin" wpa_gui
+ install -Dm644 -t "${pkgdir}/usr/share/pixmaps" icons/wpa_gui.svg
+ install -Dm644 -t "${pkgdir}/usr/share/applications" wpa_gui.desktop
+ install -Dm644 -t "${pkgdir}/usr/share/man/man8" ../doc/docbook/wpa_gui.8
}