summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a7ea43cb59b8..716b8fc54f24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname=wwwoffle
pkgver=2.9i
-pkgrel=6
-pkgdesc="Simple caching proxy server with special features for use with dial-up internet links. Includes startup scripts for OpenRC, System V init, systemd."
+pkgrel=7
+pkgdesc="Simple caching proxy server with special features (request, recursive fetch, ...) for use with dial-up internet links. Includes startup scripts for OpenRC, System V init, systemd."
arch=('i686' 'x86_64' 'arm' 'arm64')
url="http://www.gedanken.org.uk/software/wwwoffle/"
license=('GPL')
@@ -19,6 +19,8 @@ backup=('etc/wwwoffle/wwwoffle.conf')
install="${pkgname}.install"
source=(
"http://www.gedanken.org.uk/software/wwwoffle/download/${pkgname}-${pkgver}.tgz"
+ # 'certificates_4096-bits.patch'
+ # 'certificates_2048-bits.patch'
'conf_d_wwwoffle'
'initscript_openrc'
'initscript_systemd'
@@ -26,8 +28,12 @@ source=(
"${install}"
)
+### NOTE: Higher key size and other algorithms are supported in the current SVN version of wwwoffle -- so consider installing the package 'wwwoffle-svn' instead.
+
sha256sums=(
'e6341a4ec2631dc22fd5209c7e5ffe628a5832ad191d444c56aebc3837eed2ae'
+ # '3997564510edd834df09b5d1ee560403e9432a1c1b3d72614113842a3d2d2a18'
+ # '701ab0b7175a4aa8359608994614caaedd6052d588574bc3c25bd97e7705c0b8'
'cd05738f73b109dd074f6dd919300eeae55c2aa812a15e0ae61b32622423c867'
'0d5bfcd1e348f6bdad042f780b2ea8a235314d5750a66ae008a0ea391bc5cc11'
'04fd88f2a100e3ff9a96da6a70e58457252722cbf6350ffdbf08f17e62b64869'
@@ -39,6 +45,9 @@ build() {
_unpackeddir="${srcdir}/${pkgname}-${pkgver}"
cd "${_unpackeddir}"
+ # patch -p1 < "${srcdir}/certificates_4096-bits.patch"
+ # patch -p1 < "${srcdir}/certificates_2048-bits.patch"
+
./configure \
--prefix=/usr \
--exec-prefix=/usr \