summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD70
1 files changed, 52 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0355e5ada846..8e7c23b33c04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,69 @@
-# Maintainer: Peter Mattern <pmattern at arcor dot de>
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Peter Mattern <pmattern at arcor dot de>
-_pkgname=wxgtk
-pkgname=$_pkgname-git
-pkgver=r62004.4775853
+pkgname=wxgtk-git
+pkgver=3.1.5.r1546.g1c5e66a12c
pkgrel=1
-pkgdesc='Cross-Platform GUI Library - GTK+ port'
-arch=('i686' 'x86_64')
+pkgdesc="GTK+3 implementation of wxWidgets API for GUI"
+arch=(x86_64)
url='https://www.wxwidgets.org'
license=('custom: wxWindows Library Licence')
-depends=('gtk3' 'webkitgtk' 'libmspack' 'gst-plugins-bad' 'libnotify')
-makedepends=('git' 'cppunit' 'glu')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-source=("${_pkgname}::git+https://github.com/wxWidgets/wxWidgets.git")
-sha256sums=("SKIP")
+depends=(gtk3 gst-plugins-bad libnotify libsecret)
+makedepends=(git glu)
+provides=(wxgtk3 wxgtk-common)
+conflicts=(wxgtk3 wxgtk-common wxgtk2)
+source=("wxwidgets::git+https://github.com/wxWidgets/wxWidgets.git"
+ "git+https://github.com/wxWidgets/Catch.git"
+ "git+https://github.com/wxWidgets/pcre.git"
+ "git+https://github.com/wxWidgets/nanosvg")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
- cd $_pkgname
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd wxwidgets
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
- cd $_pkgname
+prepare() {
+ cd wxwidgets
+ git config submodule.3rdparty/catch.url "${srcdir}/Catch"
+ git submodule update --init 3rdparty/catch
+
+ git config submodule.3rdparty/pcre.url "${srcdir}/pcre"
+ git submodule update --init 3rdparty/pcre
+
+ git config submodule.3rdparty/nanosvg.url "${srcdir}/nanosvg"
+ git submodule update --init 3rdparty/nanosvg
+
./autogen.sh
- ./configure --prefix=/usr --with-gtk=3 --enable-stl --with-libmspack
+}
+
+build() {
+ cd wxwidgets
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --with-gtk=3 \
+ --with-opengl \
+ --enable-unicode \
+ --enable-graphics_ctx \
+ --enable-mediactrl \
+ --enable-webview \
+ --with-regex=builtin \
+ --with-libpng=sys \
+ --with-libxpm=sys \
+ --with-libjpeg=sys \
+ --with-libtiff=sys \
+ --disable-precomp-headers
make
make -C locale allmo
}
package() {
- cd $_pkgname
+ cd wxwidgets
make DESTDIR="$pkgdir" install
+
install -D -m644 docs/licence.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
}