summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 15 insertions, 36 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d7c0ab5b7996..1a5ccb531145 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,52 +4,31 @@
# Contributor: migerh <https://github.com/migerh>
# Contributor: hollunder <murks at tuxfamily dot org>
-pkgname=wxlua-svn
-pkgver=252
-pkgrel=3
-pkgdesc="A set of bindings to the wxWidgets library for the Lua programming language - svn version"
+pkgname=wxlua-git
+pkgver=WX_3_1_0.7d9d59.r17.gead9b38
+pkgrel=1
+pkgdesc="A set of bindings to the wxWidgets library for the Lua programming language - fork with Lua 5.3 support"
arch=('i686' 'x86_64' 'armv7h' 'armv8')
-url="http://wxlua.sourceforge.net"
+url="https://github.com/pkulchenko/wxlua"
license=('custom:wxWindows')
-depends=('desktop-file-utils' 'wxgtk' 'lua52')
-makedepends=('subversion' 'cmake')
+depends=('desktop-file-utils' 'wxgtk' 'lua')
+makedepends=('git' 'cmake')
provides=('wxlua' 'wxstedit')
conflicts=('wxlua' 'wxstedit')
-source=("wxlua::svn+http://svn.code.sf.net/p/${pkgname%-svn}/svn/trunk"
- "wxlstate.patch")
-md5sums=('SKIP'
- 'd4bdd1ccbb3a33abf4e7e33776811038')
+source=("git://github.com/pkulchenko/wxlua.git")
+md5sums=('SKIP')
pkgver() {
- cd ${pkgname%-svn}
- local ver="$(svnversion)"
- printf "%s" "${ver//[[:alpha:]]}"
-}
-
-prepare() {
- cd ${pkgname%-svn}
-
- sed -i -e 's/Exec=wxluaedit/Exec=wxLuaEdit/' wxLua/distrib/autopackage/wxlua.desktop
-
- # wxstedit doc folder fix
- sed -i -e 's|doc/|share/&|' wxLua/modules/wxstedit/CMakeLists.txt
-
- # fix segfault
- cd wxLua
- svn patch "$srcdir/wxlstate.patch"
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd ${pkgname%-svn}/wxLua/
+ cd ${pkgname%-git}/wxLua/
cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
- -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config \
- -DwxLua_LUA_INCLUDE_DIR=/usr/include/lua5.2 \
- -DwxLua_LUA_LIBRARY=/usr/lib/liblua.so.5.2 \
- -DwxLua_LUA_LIBRARY_USE_BUILTIN=0 \
- -DwxLua_LUA_LIBRARY_VERSION=5.2 \
-DwxWidgets_COMPONENTS="stc;gl;html;aui;adv;core;net;base" \
-DwxLuaBind_COMPONENTS="stc;gl;html;aui;adv;core;net;base" \
-DBUILD_SHARED_LIBS=TRUE
@@ -57,12 +36,12 @@ build() {
}
package() {
- cd ${pkgname%-svn}/wxLua/build
+ cd ${pkgname%-git}/wxLua/build
make DESTDIR="$pkgdir/" install
# mv lua module
- install -d "$pkgdir/usr/lib/lua/5.2"
- mv "$pkgdir/usr/lib/libwx.so" "$pkgdir/usr/lib/lua/5.2/wx.so"
+ install -d "$pkgdir/usr/lib/lua/5.3"
+ mv "$pkgdir/usr/lib/libwx.so" "$pkgdir/usr/lib/lua/5.3/wx.so"
cd ..