summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a47d8d9287b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jan Baudisch <dev@baudisch.xyz>
+pkgname=wxwabbitemu-git
+pkgver=48325ca
+pkgrel=1
+pkgdesc="A cross-platform TI-8x emulator based on Wabbitemu"
+arch=("x86_64")
+url="https://github.com/alberthdev/wxwabbitemu"
+license=("unknown")
+depends=("wxgtk3")
+source=("$pkgname::git+https://github.com/alberthdev/wxwabbitemu.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$pkgname"
+ git rev-parse --short HEAD
+}
+
+build() {
+ # linkage errors when built with optimizations
+ export CFLAGS="${CFLAGS//-O*}"
+
+ cd "$pkgname"
+ make
+}
+
+package() {
+ install -Dm755 "$pkgname/bin/wxWabbitemu" "$pkgdir/usr/bin/wxwabbitemu"
+}