summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD178
1 files changed, 178 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80589f2ea042
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,178 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgbase=wxwidgets-dev-light
+pkgname=('wxbase-dev-light'
+ 'wxgtk2-dev-light'
+ 'wxgtk3-dev-light'
+ 'wxcommon-dev-light'
+ )
+pkgver=3.1.4
+pkgrel=1
+pkgdesc="wxWidgets suite for Base and GTK2 and GTK3 toolkits . Development branch (GNOME/GStreamer free!)"
+arch=('x86_64')
+url='http://wxwidgets.org'
+license=('custom:wxWindows')
+makedepends=('git'
+ 'glu'
+ 'bash'
+ 'gtk2'
+ 'gtk3'
+ 'libsm'
+ 'libgl'
+ 'libnotify'
+ )
+source=("wxwidgets::git+https://github.com/wxWidgets/wxWidgets.git#tag=v${pkgver}"
+ 'make-abicheck-non-fatal.patch'
+ 'git+https://github.com/wxWidgets/Catch.git'
+ 'wxGTK-collision.patch'
+ )
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ )
+
+prepare() {
+ mkdir -p build-{base,gtk{2,3}}
+
+ cd wxwidgets
+
+ git config submodule.3rdparty/catch.url "${srcdir}/Catch"
+ git submodule update --init 3rdparty/catch
+
+ patch -Np1 -i "${srcdir}/wxGTK-collision.patch"
+
+ # C++ ABI check is too strict and breaks with GCC 5.1
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1200611
+ patch -Np1 -i "${srcdir}/make-abicheck-non-fatal.patch"
+}
+
+build() {
+ msg2 "Build WxBASE"
+ cd "${srcdir}/build-base"
+ ../wxwidgets/configure \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --with-regex=builtin \
+ --disable-{precomp-headers,gui}
+
+ make
+ make -C ../wxwidgets/locale allmo
+
+ msg2 "Build WxGTK2"
+ cd "${srcdir}/build-gtk2"
+ ../wxwidgets/configure \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --with-gtk=2 \
+ --with-lib{jpeg,png,tiff,xpm}=sys \
+ --with-regex=builtin \
+ --with-{opengl,sdl} \
+ --enable-graphics_ctx \
+ --without-gnomevfs \
+ --disable-{gtktest,sdltest,precomp-headers,mediactrl,webview}
+
+ make
+ make -C ../wxwidgets/locale allmo
+
+ msg2 "Build WxGTK3"
+ cd "${srcdir}/build-gtk3"
+ ../wxwidgets/configure \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --with-gtk=3 \
+ --with-lib{jpeg,png,tiff,xpm}=sys \
+ --with-regex=builtin \
+ --with-{opengl,sdl} \
+ --enable-graphics_ctx \
+ --without-gnomevfs \
+ --disable-{gtktest,sdltest,precomp-headers,mediactrl,webview}
+
+ make
+ make -C ../wxwidgets/locale allmo
+}
+
+package_wxbase-dev-light() {
+ pkgdesc="wxWidgets Base. Development branch (GNOME/GStreamer free!)"
+ depends=('wxcommon-light'
+ 'bash'
+ 'expat'
+ 'zlib'
+ )
+ provides=('wxbase-dev')
+ conflicts=('wxbase-dev')
+ options=('!emptydirs')
+
+ make -C build-base DESTDIR="${pkgdir}" install
+
+ mv "${pkgdir}/usr/bin/wx-config-3.1" "${pkgdir}/usr/bin/wx-config-base-3.1"
+ rm -fr "${pkgdir}/usr/include"
+ rm -fr "${pkgdir}/usr/share"
+
+ install -Dm644 wxwidgets/docs/licence.txt "${pkgdir}/usr/share/licenses/wxbase-dev-light/LICENSE"
+}
+
+package_wxgtk2-dev-light() {
+ pkgdesc="wxWidgets GTK2 Toolkit. Development branch (GNOME/GStreamer free!)"
+ depends=('wxcommon-light'
+ 'libgl'
+ 'gtk2'
+ 'libsm'
+ 'sdl2'
+ 'libnotify'
+ )
+ provides=('wxgtk2-dev')
+ conflicts=('wxgtk2-dev')
+ options=('!emptydirs')
+
+ make -C build-gtk2 DESTDIR="${pkgdir}" install
+
+ cp -P "${pkgdir}/usr/bin/wx-config-3.1" "${pkgdir}/usr/bin/wx-config-gtk2-3.1"
+ rm -fr "${pkgdir}/usr/bin/"wxrc{,-3.1}
+ rm -fr "${pkgdir}/usr/include"
+ rm -fr "${pkgdir}/usr/lib/"*baseu*
+ rm -fr "${pkgdir}/usr/share"
+
+ install -Dm644 wxwidgets/docs/licence.txt "${pkgdir}/usr/share/licenses/wxgtk2-dev-light/LICENSE"
+}
+
+package_wxgtk3-dev-light() {
+ pkgdesc="wxWidgets GTK3 Toolkit. Development branch (GNOME/GStreamer free!)"
+ depends=('wxcommon-light'
+ 'gtk3'
+ 'libsm'
+ 'sdl2'
+ 'libnotify'
+ )
+ provides=('wxgtk3-dev')
+ conflicts=('wxgtk3-dev')
+ options=('!emptydirs')
+
+ make -C build-gtk3 DESTDIR="${pkgdir}" install
+
+ mv "${pkgdir}/usr/bin/wx-config-3.1" "${pkgdir}/usr/bin/wx-config-gtk3-3.1"
+ rm -fr "${pkgdir}/usr/bin/"wxrc{,-3.1}
+ rm -fr "${pkgdir}/usr/include"
+ rm -fr "${pkgdir}/usr/lib/"*baseu*
+ rm -fr "${pkgdir}/usr/share"
+
+ install -Dm644 wxwidgets/docs/licence.txt "${pkgdir}/usr/share/licenses/wxgtk3-dev-light/LICENSE"
+}
+
+package_wxcommon-dev-light() {
+ pkgdesc="wxWidgets common. Development branch (GNOME/GStreamer free!)"
+ depends=('wxbase-light')
+ provides=('wxgtk-common-dev')
+ conflicts=('wxgtk-common-dev')
+ options=('!emptydirs')
+
+ make -C build-gtk2 DESTDIR="${pkgdir}" install
+ make -C build-gtk3 DESTDIR="${pkgdir}" install
+ make -C build-base DESTDIR="${pkgdir}" install
+
+ rm -fr "${pkgdir}/usr/bin/wx-config-3.1"
+ rm -fr "${pkgdir}/usr/lib"
+ rm -fr "${pkgdir}/usr/share/locale/it/LC_MESSAGES/wxmsw.mo"
+
+ install -Dm644 wxwidgets/docs/licence.txt "${pkgdir}/usr/share/licenses/wxcommon-dev-light/LICENSE"
+}