summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 6 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e970703806dc..1704d40aa73e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: MCMic <come@chilliet.eu>
pkgname=wyrmsun
-pkgver=5.3.5
-pkgrel=3
+pkgver=5.3.6
+pkgrel=1
pkgdesc="Real-time strategy game based on history, mythology and fiction"
arch=('i686' 'x86_64')
url="https://andrettin.github.io/"
@@ -19,18 +19,9 @@ depends=('hicolor-icon-theme'
'tolua++')
makedepends=('boost' 'cmake' 'glu')
source=("wyrmsun-${pkgver}.tar.gz::https://github.com/Andrettin/Wyrmsun/archive/v${pkgver}.tar.gz"
- "wyrmgus-${pkgver}.tar.gz::https://github.com/Andrettin/Wyrmgus/archive/v${pkgver}.tar.gz"
- 'werror_format_security.patch')
-md5sums=('f519b26169499e52517196b24813d2ac'
- '73b2e1bf4e29c0663af23d025c104f7c'
- '426efa2e8ee8b3ab46736d634599963c')
-
-prepare() {
- cd "${srcdir}/Wyrmgus-${pkgver}"
- # This patch fixes the compilation error with the -Werror=format_security flag
- # until a new version is released.
- patch src/player/player.cpp "${srcdir}/werror_format_security.patch"
-}
+ "wyrmgus-${pkgver}.tar.gz::https://github.com/Andrettin/Wyrmgus/archive/v${pkgver}.tar.gz")
+md5sums=('fd77be9c4e3c425b0cab35c3545ddbba'
+ '3210ec84d8ef96d6c352ecc149d4c82c')
build() {
cd "${srcdir}/Wyrmgus-${pkgver}"
@@ -40,6 +31,7 @@ build() {
-DWITH_GEOJSON=OFF \
-DCMAKE_C_FLAGS="$CFLAGS -DNDEBUG" \
-DCMAKE_CXX_FLAGS="$CXXFLAGS -DNDEBUG" \
+ -DENABLE_USEGAMEDIR=OFF \
-Wno-dev
cmake --build . --target wyrmgus_main