summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da9c5836ac25..095624eba4a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,25 +9,24 @@ license=('MIT')
arch=('i686' 'x86_64')
depends=('xdotool' 'xorg-xmodmap')
-makedepends=('git' 'ghc' 'cabal-install')
+makedepends=('git') #this also needs stack, but usually stack is installed locally
source=("git+https://github.com/apirogov/${pkgname}.git")
md5sums=('SKIP')
# PKGBUILD functions
+prepare() {
+ cd ${srcdir}/${pkgname}
+ stack install --only-snapshot
+
+}
build() {
cd ${srcdir}/${pkgname}
-
- cabal update
-
- cabal sandbox init
- cabal install --only-dependencies
- cabal configure -O --prefix=/usr
- cabal build
+ stack build
}
package() {
cd ${srcdir}/${pkgname}
- cabal copy --destdir=${pkgdir}
+ stack install --local-bin-path=${pkgdir}
}