summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6de75bc27f8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: DrZaius <lou[at]fakeoutdoorsman.com>
+
+pkgname=x262-git
+pkgver=0.142.2633.bb887aa
+pkgrel=1
+pkgdesc="x264 with MPEG-2 video support (GIT version)"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('glibc' 'ffms2')
+makedepends=('git' 'yasm')
+url="http://git.videolan.org/?p=x262.git"
+source=('git://git.videolan.org/x262.git')
+provides=('x262')
+conflicts=('x262')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd x262
+ echo "$(sh version.sh | grep 'X264_POINTVER' | cut -d '"' -f2 | tr M m | tr ' ' .)"
+}
+
+build() {
+ cd x262
+ ./configure \
+ --prefix=/usr \
+ --disable-lsmash
+
+ make
+}
+
+package() {
+ make -C x262 DESTDIR="${pkgdir}" install
+ rm -fr "${pkgdir}/usr/bin/x262"
+ mv "${pkgdir}/usr/bin/x264" "${pkgdir}/usr/bin/x262"
+}