summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 15 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e91d92b78e3a..b43729a00ae2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Maintainer : Daniel Bermond <dbermond@archlinux.org>
# Contributor: Det <nimetonmaili at-gmail a-dot com>
# Contributor: PelPix <kylebloss[at]pelpix[dot]info>
# Contributor: DrZaius <lou[at]fakeoutdoorsman.com>
@@ -13,19 +13,18 @@
# 10-bit, please see, e.g.: https://gist.github.com/l4n9th4n9/4459997
pkgname=x264-git
-pkgver=157.r2969.gd4099dd4
+pkgver=161.r3042.gb3aadb76
pkgrel=1
arch=('x86_64')
-pkgdesc='Open Source H264/AVC video encoder (git version)'
+pkgdesc='Open Source H.264/AVC video encoder (git version)'
url='https://www.videolan.org/developers/x264.html'
license=('GPL')
-depends=('libavcodec.so' 'libavformat.so' 'libavutil.so' 'liblsmash.so'
- 'libswscale.so')
-makedepends=('git' 'nasm' 'ffmpeg' 'l-smash')
+depends=('liblsmash.so')
+makedepends=('git' 'nasm' 'l-smash')
provides=('x264' 'libx264' 'libx264-git' 'libx264.so')
conflicts=('x264' 'libx264' 'libx264-10bit' 'libx264-all')
replaces=('libx264-git' 'libx264-10bit-git' 'libx264-all-git')
-source=('git+https://git.videolan.org/git/x264.git')
+source=('git+https://code.videolan.org/videolan/x264.git')
sha256sums=('SKIP')
prepare() {
@@ -33,17 +32,9 @@ prepare() {
}
pkgver() {
- cd x264
-
- local _version
- local _revision
- local _shorthash
-
- _version="$(grep '#define X264_BUILD' x264.h | awk '{ print $3 }')"
- _revision="$( git rev-list --count HEAD)"
- _shorthash="$(git rev-parse --short HEAD)"
-
- printf '%s.r%s.g%s' "$_version" "$_revision" "$_shorthash"
+ printf '%s.r%s.g%s' "$(grep '#define X264_BUILD' x264/x264.h | awk '{ print $3 }')" \
+ "$(git -C x264 rev-list --count HEAD)" \
+ "$(git -C x264 rev-parse --short HEAD)"
}
build() {
@@ -55,6 +46,9 @@ build() {
--bit-depth='8' \
--enable-lto \
--enable-pic \
+ --disable-avs \
+ --disable-swscale \
+ --disable-lavf \
--disable-gpac
make
@@ -68,6 +62,9 @@ build() {
--bit-depth='10' \
--enable-lto \
--enable-pic \
+ --disable-avs \
+ --disable-swscale \
+ --disable-lavf \
--disable-gpac
make
}