summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6aa5842a1b89..1fca72ac8a45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
# 10-bit, please see, e.g.: https://gist.github.com/l4n9th4n9/4459997
pkgname=x264-git
-pkgver=157.r2932.g303c484e
+pkgver=157.r2935.g545de2ff
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Open Source H264/AVC video encoder (git version)'
@@ -23,8 +23,7 @@ depends=('libavcodec.so' 'libavformat.so' 'libavutil.so' 'liblsmash.so'
'libswscale.so')
makedepends=('git' 'nasm' 'ffmpeg' 'l-smash')
provides=('x264' 'libx264' 'libx264-git' 'libx264.so')
-conflicts=('x264' 'libx264' 'libx264-10bit' 'libx264-all'
- 'libx264-git' 'libx264-10bit-git' 'libx264-all-git')
+conflicts=('x264' 'libx264' 'libx264-10bit' 'libx264-all')
replaces=('libx264-git' 'libx264-10bit-git' 'libx264-all-git')
source=("$pkgname"::'git+https://git.videolan.org/git/x264.git')
sha256sums=('SKIP')
@@ -46,7 +45,7 @@ pkgver() {
build() {
mkdir -p "$pkgname"/build-{8,10}bit
- msg2 'Building for 8-bit...'
+ printf '%s\n' ' -> Building for 8-bit...'
cd "${pkgname}/build-8bit"
../configure \
--prefix='/usr' \
@@ -57,7 +56,7 @@ build() {
--disable-gpac
make
- msg2 'Building for 10-bit...'
+ printf '%s\n' ' -> Building for 10-bit...'
cd ../build-10bit
../configure \
--prefix='/usr' \
@@ -78,7 +77,7 @@ package() {
for _depth in 10 8
do
- msg2 "Installing for ${_depth}-bit..."
+ printf '%s\n' " -> Installing for ${_depth}-bit..."
make -C "build-${_depth}bit" DESTDIR="$pkgdir" install-cli install-lib-shared
if [ "$_depth" -eq '10' ]