summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 19 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da58882a9e2a..c4a859207107 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,32 @@
# Maintainer: Milan Knížek <knizek@volny.cz>
pkgname=x2godesktopsharing
-pkgver=3.1.1.2
-pkgrel=3
-pkgdesc="x2godesktopsharing is an X2Go add-on tool that allows a user to grant other X2go users access to the current session (shadow session support)."
-arch=('i686' 'x86_64')
+pkgver=3.1.1.3
+pkgrel=1
+pkgdesc="X2Go add-on tool that allows a user to grant other X2go users access to the current session (shadow session support)."
+arch=('x86_64')
url="http://www.x2go.org/"
license=('GPL')
depends=('x2goserver>=4.0.1' 'qt4>=4.5')
options=(emptydirs)
-install=$pkgname.install
groups=('x2go' 'alts')
-options=(!strip)
-source=('sharetray.cpp.patch'
- "http://code.x2go.org/releases/source/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('2efa3a30be77489dbc22188584a93690'
- 'bd48394f5a4eaa55559622f21a5e0a79')
+source=("https://code.x2go.org/releases/source/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ "https://code.x2go.org/releases/source/${pkgname}/${pkgname}-${pkgver}.tar.gz.asc"
+ 'x2godesktopsharing-sysusers.conf')
+md5sums=('e5d4c4393ed5dde7e0790d7cded56cc2'
+ 'SKIP'
+ 'd10b90b9a038bed5e91ba821d8ac874c')
+sha1sums=('1d94ffb31756c36b7071c53b214b0941244482b6'
+ 'SKIP'
+ 'd3fa5d6ba6aa0a9d6925b97bf0ae51581cdabd8d')
+sha512sums=('e6a8ee81cbc2211951d0676fad5fd4102069dd66a013e74a955e28c0a1e5429ef1a334a9b028ec278633c61f59e66c29e329f4a2a4354263fce359035c12ed6f'
+ 'SKIP'
+ '67aae752373174504d5b2de52f2b4bb195cc111033525a9e166bcd0da79ef9be0295850666050f1847a9f2895bb20656b3f1ca82b4c0565d2c35769be6542e4f')
+validpgpkeys=('1AD23D1B8F087A35AB74BDE9F4A7678C9C6B0B2B')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
-# echo "CONFIG = qt x11 dll debug" >> x2godesktopsharing.pro
- patch -Np1 -i "${srcdir}/sharetray.cpp.patch"
qmake-qt4 x2godesktopsharing.pro
-# cp ../Makefiledbg Makefile
make
}
@@ -68,4 +72,6 @@ package() {
echo ${pkgver} > "${pkgdir}/usr/share/x2go/versions/VERSION.$pkgname"
install -D -m 755 "share/x2gofeature.d/x2godesktopsharing.features" "${pkgdir}/usr/share/x2go/x2gofeature.d/x2godesktopsharing.features"
+
+ install -D -m 644 "$srcdir/x2godesktopsharing-sysusers.conf" "$pkgdir/usr/lib/sysusers.d/x2godesktopsharing.conf"
}