summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc7ab206b732..0f1c9610a17f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname='xampp'
_srcver='8.2.0'
_binver=0
-pkgrel=1
+pkgrel=2
# This PKGBUILD deals with two different versioning formats: the upstream
# format MAJOR.MINOR.REVISION-BUILD - used internally by XAMPP - and the
@@ -111,7 +111,7 @@ package() {
# Root location in all files
msg 'Setting root location globally (it might take a few minutes)...'
find "${pkgdir}${_xampp_root}/" -type f \
- -exec sed -i "s/@@BITNAMI_XAMPP_ROOT@@\|@@BITROCK_INSTALLDIR@@/$(_sed_escape "${_xampp_root}")/gI" '{}' \;
+ -exec sed -i "s/@@BITNAMI_XAMPP_ROOT@@\|@@BITROCK_INSTALLDIR@@\|@@XAMPP_INSTALLDIR@@/$(_sed_escape "${_xampp_root}")/gI" '{}' \;
# Temp folders
install -dm777 "${pkgdir}${_xampp_root}/phpmyadmin/tmp"
@@ -133,6 +133,9 @@ package() {
test -d "${pkgdir}${_xampp_root}/share/lampp" || \
ln -sf "${_xampp_root}/share/xampp" "${pkgdir}${_xampp_root}/share/lampp"
+ echo "Include \"${_xampp_root}/apache2/conf/httpd.conf\"" >> \
+ "${pkgdir}${_xampp_root}/etc/httpd.conf"
+
msg 'Copying executables and launcher...'
# Licenses