summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a4e0849868f7..6dff1c9936bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Eli Schwartz <eschwartz@archlinux.org>
pkgname=xapps-git
-pkgver=1.6.9.r9.gd6203cb
-pkgrel=2
+pkgver=1.8.0.r3.g5b59768
+pkgrel=1
pkgdesc="Common library for X-Apps project"
arch=('i686' 'x86_64')
url="https://github.com/linuxmint/${pkgname%-git}"
license=('GPL')
-depends=('libgnomekbd')
-makedepends=('git' 'meson' 'samurai' 'gobject-introspection' 'python-gobject' 'python2-gobject' 'vala')
+depends=('libdbusmenu-gtk3' 'libgnomekbd')
+makedepends=('git' 'meson' 'samurai' 'gobject-introspection' 'python-gobject' 'vala')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("git+${url}.git")
@@ -41,11 +41,9 @@ package(){
# byte-compile python modules since meson does not implement autotools'
# py-compile.
# This is kind of ugly but removes traces of the build root.
- for _python in python3 python2; do
- while read -rd '' _file; do
- _destdir="$(dirname "${_file#${pkgdir}}")"
- ${_python} -m compileall -d "${_destdir}" "${_file}"
- ${_python} -O -m compileall -d "${_destdir}" "${_file}"
- done < <(find "${pkgdir}"/usr/lib/${_python}* -name '*.py' -print0)
- done
+ while read -rd '' _file; do
+ _destdir="$(dirname "${_file#${pkgdir}}")"
+ python -m compileall -d "${_destdir}" "${_file}"
+ python -O -m compileall -d "${_destdir}" "${_file}"
+ done < <(find "${pkgdir}"/usr/lib/python3* -name '*.py' -print0)
}