summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d74558a31276..4877aa663848 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,37 @@
-# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Maintainer: Daniel Bermond <dbermond@archlinux.org>
# NOTE:
-# 10-bit depth currently fails to build
-# https://github.com/pkuvcl/xavs2/issues/9
+# 10-bit depth is not supported currently
+# https://github.com/pkuvcl/xavs2/blob/1.4/build/linux/configure#L500
pkgname=xavs2
-pkgver=1.3
-pkgrel=2
+pkgver=1.4
+pkgrel=1
arch=('x86_64')
pkgdesc='Open-Source encoder of AVS2-P2/IEEE1857.4 video coding standard'
url='https://github.com/pkuvcl/xavs2/'
license=('GPL')
depends=('glibc' 'liblsmash.so')
-makedepends=('yasm' 'l-smash')
+makedepends=('nasm' 'l-smash')
provides=('libxavs2')
conflicts=('libxavs2')
replaces=('libxavs2')
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/pkuvcl/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('28f9204dc9384336de7c6210cd3317d2d6b94ec23a4d1b6113fcbe7f00d7230b')
+options=('!lto')
+source=("https://github.com/pkuvcl/xavs2/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('1e6d731cd64cb2a8940a0a3fd24f9c2ac3bb39357d802432a47bc20bad52c6ce')
build() {
cd "${pkgname}-${pkgver}/build/linux"
-
./configure \
--prefix='/usr' \
- --extra-ldflags='-Wl,-z,noexecstack' \
--enable-shared \
--bit-depth='8' \
--chroma-format='all' \
- --enable-lto \
--enable-pic \
--disable-swscale \
--disable-lavf \
--disable-ffms \
--disable-gpac
-
make
}