summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 18cb8189ed82..b56ad32ee5ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Steve Engledow <steve@offend.me.uk>
pkgname=xbindkeys-git
-pkgver=git
-pkgrel=1
+pkgrel=2
+pkgver=v1.8.7.r1.g75909d9
pkgdesc='xbindkeys is a program that allows you to launch shell commands with your keyboard or your mouse under X Windows'
url='https://www.nongnu.org/xbindkeys/xbindkeys.html'
arch=(any)
@@ -18,6 +18,11 @@ source=('git+https://git.savannah.nongnu.org/git/xbindkeys.git')
sha256sums=('SKIP')
provides=('xbindkeys')
+pkgver() {
+ cd xbindkeys
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
cd xbindkeys
./configure --prefix=/usr