summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 23 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 26cd889dac47..18cb8189ed82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,30 @@
-# Maintainer: Yusuf Aktepe <yusuf@yusufaktepe.com>
-# Contributor: Florian Pritz <bluewind@xinu.at>
-# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
-# Contributor: Thayer Williams <thayer@archlinux.org>
-
-pkgname=xbindkeys
-pkgver=1.8.7
+# Maintainer: Steve Engledow <steve@offend.me.uk>
+pkgname=xbindkeys-git
+pkgver=git
pkgrel=1
-pkgdesc="Launch shell commands with your keyboard or your mouse under X"
-arch=('x86_64')
-url="https://www.nongnu.org/xbindkeys/xbindkeys.html"
-license=('GPL')
-depends=('libx11' 'guile')
-optdepends=('tk: xbindkeys_show')
-source=(https://www.nongnu.org/${pkgname}/${pkgname}-${pkgver}.tar.gz)
-sha256sums=('a29b86a8ec91d4abc83b420e547da27470847d0efe808aa6e75147aa0adb82f2')
+pkgdesc='xbindkeys is a program that allows you to launch shell commands with your keyboard or your mouse under X Windows'
+url='https://www.nongnu.org/xbindkeys/xbindkeys.html'
+arch=(any)
+license=('GPL2')
+depends=(
+ 'guile'
+ 'libx11'
+)
+optdepends=(
+ 'tk'
+)
+makedepends=('git')
+source=('git+https://git.savannah.nongnu.org/git/xbindkeys.git')
+sha256sums=('SKIP')
+provides=('xbindkeys')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr
- make
+ cd xbindkeys
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd xbindkeys
+ make install prefix="$pkgdir/usr/"
}