summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 76ff8e5736e2..4c3b5e6d9e30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Stunts <f.pinamartins@gmail.com>
pkgname=xboxdrv-develop-git
_pkgname=xboxdrv
-pkgver=0.8.4.r410.g1aebab2
+pkgver=0.8.4.r457.gc12c2b5
pkgrel=1
pkgdesc="An XBox/XBox 360 gamepad driver - as alternative to the xpad-kernel module - with more configurability, runs in userspace and supports a multitude of controllers. Bleeding edge version."
arch=('i686' 'x86_64')
url="https://xboxdrv.gitlab.io"
license=('GPL3')
-depends=('libx11' 'dbus-glib' 'libusbx')
-makedepends=('git' 'scons' 'boost' 'pkg-config' 'libx11' 'dbus-glib' 'libusb')
+depends=('libx11' 'dbus-glib' 'libusb' 'dbus-python' 'systemd' 'fmt' 'bluez-libs')
+makedepends=('git' 'scons' 'boost' 'pkg-config')
provides=('xboxdrv')
conflicts=('xboxdrv')
source=('git+https://gitlab.com/xboxdrv/xboxdrv.git#branch=develop'
@@ -18,6 +18,10 @@ sha256sums=('SKIP'
'51387a52a97d2e004a4160432131f18326e9ae655447694e170f18bdb8d7204f'
'f155dd059faecafa60ecaa0988aec815ee0c58f1af45075de82ae10c31db2750')
+prepare() {
+ cd ${srcdir}/${_pkgname}
+ git submodule update --recursive --init
+}
pkgver() {
cd ${srcdir}/${_pkgname}